poj2828- Buy Tickets

Time Limit:4000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…




The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.




It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!




People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.




Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:




Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.




Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.




Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.




题目大意:一群人排队买票,给出他们的编号,和刚来时插入的位置 如第一个样例,第一个人来的时候肯定是插在
0后面第二个人来插到第一个人后面,这是队列为77 51 滴三个人来了插到第1个人后面 现在队列为77 33 51,第四个人插在第二个后面 现在队列为77 33 69 51.


思路:从后面往前面推,因为最后一个人的位置肯定是确定的,最后一个人就把那个位置给占了,接下来一个一个往
前面推因为每个人前面原本的人数是固定了 所以当这个人插入的时候前面必须留它插入的位置的人数给前面还没推

的人占,比如说第i个人的前面有3个人(既第i个人一开始插入第3个人的后面)这时候第i个人的前面必须留有三个空位。然后自己在第四个空位坐下,然后那个节点变为0,每个区间记录下自己当前区间剩余的位置如果不够,就往右区间查找并且将vis(vis含义看代码)减去左区间的剩余位置。



代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct tree
{
    int l, r,len;
	int mid()
	{
	    return (l + r) >>1;
	}
}t[1000000];
int ans ;
int a[210000],b[210000],c[800005],w;
void btree(int l,int r, int now)
{
	t[now].l = l;
	t[now].r = r;
    if(l == r)
	{
	    t[now].len = 1;
		return;
	}
	int mid = t[now].mid();
	btree(l,mid,now<<1);
	btree(mid+1,r,now<<1|1);
	t[now].len += t[now<<1].len + t[now<<1|1].len;
}
void pdate(int l, int r, int now ,int vis)    //vis代表前面需要留有多数空位
{
    if(l == r)
	{
	     c[now] = w;
		 t[now].len = 0;
		 return;
	}
	int mid = t[now].mid();
	if(t[now<<1].len >= vis)
	{
	    pdate(l,mid,now<<1,vis);
	}
	else 
	{
	    pdate(mid+1,r,now<<1|1,vis-t[now<<1].len);
	}
	t[now].len = t[now<<1].len + t[now<<1|1].len; 
}
void print(int l, int r, int now)        //这个是我想太多了其实只要把上面的c[now] = w改成c[l] = w,然后在主程序里面for循环从1到n输出就行了
{
    if(l == r)
	{
	    printf("%d ",c[now]);
		return ;
	}
	int mid = t[now].mid();
	print(l, mid, now<<1);
	print(mid+1,r,now<<1|1);
}
int main()
{
	int n,i;
	while (scanf("%d",&n)!=EOF)
	{
		memset(c,0,sizeof(c));
		btree(1,n,1);
	    for(i = 1; i <= n; i++)
		{
		    scanf("%d %d",&a[i],&b[i]);
		}
		for(i = n; i>=1;i--)
		{
		    ans = 0;
			w = b[i];
            pdate(1,n,1,a[i]+1);
			if(b[i] == 0)
			    c[ans] = -1;
			else 
				c[ans] = b[i];
		}
		print(1,n,1);
		cout<<endl;
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值