数据结构实验之二叉树五:层序遍历

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

输入

  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。

输出

  输出二叉树的层次遍历序列。

示例输入

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

abcdefg
xnuli

提示

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data;
    struct node *l,*r;
};
int cnt;
char s[100];
struct node *creat(struct node *q)
{
    cnt++;
    if(s[cnt] == ',')
    {
        q = NULL;
    }
    else
    {
        q  = (struct node *)malloc(sizeof(struct node));
        q->data = s[cnt];
        q->l = creat(q->l);
        q->r = creat(q->r);
    }
    return q;
}
void seque(struct node *tree)
{
    struct node *q[100];
    int head = 0;
    int tail = 1;
    q[head] = tree;
    while(head < tail){
        if(q[head] != NULL){
            printf("%c", q[head]->data);
            q[tail++] = q[head]->l;
            q[tail++] = q[head]->r;
        }
        head++;
    }
}
int main()
{
    struct node *tree;
    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%s", s);
        cnt =-1;
        tree = creat(tree);
        seque(tree);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值