hdu 4960 Another OCD Patient

Another OCD Patient

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 87    Accepted Submission(s): 24


Problem Description
Xiaoji is an OCD (obsessive-compulsive disorder) patient. This morning, his children played with plasticene. They broke the plasticene into N pieces, and put them in a line. Each piece has a volume Vi. Since Xiaoji is an OCD patient, he can't stand with the disorder of the volume of the N pieces of plasticene. Now he wants to merge some successive pieces so that the volume in line is symmetrical! For example, (10, 20, 20, 10), (4,1,4) and (2) are symmetrical but (3,1,2), (3, 1, 1) and (1, 2, 1, 2) are not.

However, because Xiaoji's OCD is more and more serious, now he has a strange opinion that merging i successive pieces into one will cost ai. And he wants to achieve his goal with minimum cost. Can you help him?

By the way, if one piece is merged by Xiaoji, he would not use it to merge again. Don't ask why. You should know Xiaoji has an OCD.
 

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 5000), indicating the number of pieces in a line. The second line contains N integers Vi, volume of each piece (0 < Vi <=10^9). The third line contains N integers ai  (0 < ai <=10000), and a1 is always 0. 

The input is terminated by N = 0.
 

Output
Output one line containing the minimum cost of all operations Xiaoji needs.
 

Sample Input
  
  
5 6 2 8 7 1 0 5 2 10 20 0
 

Sample Output
  
  
10
Hint
In the sample, there is two ways to achieve Xiaoji's goal. [6 2 8 7 1] -> [8 8 7 1] -> [8 8 8] will cost 5 + 5 = 10. [6 2 8 7 1] -> [24] will cost 20.
 

Source
 

题解及代码:

官方题解:

           

思路和官方是一样的,但是比赛时还是没 写出来,比赛后修修改改就过了,好忧桑啊.....

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
typedef __int64  ll;
ll org[5010],l[5010],r[5010];
ll val[5010],d[2510];

struct node
{
    int l,r;
} pos[5010];

map<ll,int>m;
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        m.clear();
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&org[i]);
            if(i==1)
                l[i]=org[i];
            else l[i]=l[i-1]+org[i];
            m[l[i]]=i;
        }

        int k=1,flag=1;
        pos[0].l=pos[0].r=0;
        for(int i=n; i>=1; i--)
        {
            if(i==n)
                r[i]=org[i];
            else r[i]=r[i+1]+org[i];
            if(flag&&m.find(r[i])!=m.end())
            {
                pos[k].l=m[r[i]];
                pos[k].r=n-i+1;
                if(pos[k].l+pos[k].r>=n)
                {
                    flag=0;
                }
                k++;
            }
        }
        k--;

        /*for(int i=0;i<=k;i++)
        {
            printf("l:%d r:%d\n",pos[i].l,pos[i].r);
        }
         */
        int mid;
        if(pos[k].l+pos[k].r==n)
        {
            mid=0;
        }
        else
        {
            k--;
            mid=n-pos[k].r-pos[k].l;
        }
        //printf("k:%d mid:%d\n",k,mid);

        val[0]=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%I64d",&val[i]);
        }

        ll ans=-1;
        d[0]=0;
        for(int i=1; i<=k; i++)
        {
            d[i]=val[pos[i].l]+val[pos[i].r];
            for(int j=1; j<i; j++)
            {
                d[i]=min(d[j]+val[pos[i].l-pos[j].l]+val[pos[i].r-pos[j].r],d[i]);
            }
        }

        for(int i=0; i<=k; i++)
        {
            if(ans==-1||ans>d[i]+val[mid+pos[k].l-pos[i].l+pos[k].r-pos[i].r])
                ans=d[i]+val[mid+pos[k].l-pos[i].l+pos[k].r-pos[i].r];
        }
        printf("%I64d\n",ans);
    }
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值