POJ 1050 To the Max(DP)

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47559 Accepted: 25161

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


经典DP题,求子矩阵最大值。解法很简单,我们把2维的看做一维的来处理,这样就成了线性DP。首先要枚举出来矩阵的上下两行Li,Lj (1<=i<=j<=N),把同一列的【i,k】(Li<=i<=Lj)值加一起变成一个数据,每一列都求和,最后一行会有M个数据,就变成了经典的求连续子序列最大和问题,枚举N*(N+1)/2次,找出最大值就是我们想求得结果。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define inf 0x6fffffff
#define LL long long
using namespace std;
int a[110][110],p[110][110];
int main()
{
    int n,maxx=0;
    cin>>n;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)scanf("%d",a[i]+j);
    for(int i=1;i<=n;i++){
        for(int j=i;j<=n;j++){
            int t=0;
            for(int k=1;k<=n;k++){
                p[i][k]+=a[j][k];
                if(t>=0)t+=p[i][k];
                else t=p[i][k];
                maxx=max(t,maxx);
            }
        }
    }
    cout<<maxx<<endl;

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值