HDU 1142 A Walk Through the Forest (SPFA+记忆化DFS)

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647 
Sample Input
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0
Sample Output
2
4



题意:题意很坑人,题面说了 A是否可以到B的判断就是A到2的最短距离大于B到2的最短距离,问从1到2有多少不同的路。


分析:  首先求出2到其他点的最短距离,然后从1深搜到2的路,其中深搜的时候需要记录各个点到点2的不同数量。

代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(i,j,k) for(int i=j; i<k; i++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;
const int mod=1e9+7;
struct SD{
    int x;
    int l;
    bool operator <(const struct SD &a)const{

        return l>a.l;
    }
}a[2100000],p,pp;
int f[50000],bk[1100];
int n,m,k,maxx,ans,cur,sum,x,y;
int minn;
int nex[4][2]={0,1,1,0,0,-1,-1,0};
char mapp[1100][1100];
int cc[1100];
int dis[1100];
vector<struct SD> v[1100];
queue<struct SD> q;
void spfa(){
    while(q.size())q.pop();
    mem(bk,0);
    bk[2]=1;
    p.x=2,p.l=0;
    q.push(p);
    dis[2]=0;
    while(q.size()){
        p=q.front();
        //cout<<p.x<<"  "<<cc[p.x]<<endl;
        q.pop();
        bk[p.x]=0;
        int le=v[p.x].size();
        for(int i=0;i<le;i++){
            int vv=v[p.x][i].x;
            if(dis[vv]>=dis[p.x]+v[p.x][i].l){
                if(dis[vv]>dis[p.x]+v[p.x][i].l){
                        dis[vv]=dis[p.x]+v[p.x][i].l;
                        if(!bk[vv]){
                             bk[vv]=1;
                             pp.x=vv;
                             q.push(pp);
                        }
                }
            }

        }

    }
}
int dfs(int x){
    //cout<<x<<endl;
    if(cc[x]!=-1)return cc[x];
    if(x==2)return 1;
    int le=v[x].size(),ans=0;
    for(int i=0;i<le;i++){
        if(dis[x]>dis[v[x][i].x]){//cout<<"asdsad"<<endl;
            ans+=dfs(v[x][i].x);
        }
    }
    cc[x]=ans;
    return ans;
}
int main()
{
    while(cin>>n&&n){
        cin>>m;
        int l,le=0;
        mem(mapp,0);
        for(int i=0;i<=n;i++)v[i].clear(),dis[i]=1000000000,cc[i]=-1;
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&x,&y,&l);
            if(mapp[x][y])continue;
            mapp[x][y]=mapp[y][x]=1;
            a[le].x=y,a[le].l=l;
            v[x].pb(a[le++]);
            a[le].x=x,a[le].l=l;
            v[y].pb(a[le++]);
        }
        spfa();
        //for(int i=1;i<=n;i++)cout<<dis[i]<<endl;
        cout<<dfs(1)<<endl;
    }


    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值