HDU-Euler theorem(欧拉定理)

Euler theorem

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1322 Accepted Submission(s): 868

Problem Description

HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.

Input

The first line contains a positive integer T(1≤T≤5), denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1≤a≤109).

Output

For each test case:
A single line contains a nonnegative integer, denoting the answer.

Sample Input

2
1
3

Sample Output

2
3

解析

题目的意思是给出一个a,对于任意的b,得到c=a%b,求c的种类
思路:很明显0和a本身是符合的,然后多于a/2都符合,所以答案就是(a-1)/2+2;

代码

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int T,a;
    for(scanf("%d",&T);T--;)
    {
        scanf("%d",&a);
        printf("%d\n",(a-1)/2+2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值