Hie with the Pie(旅行商问题)

Hie with the Pie

题目链接

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

题目大意

题目大概的意思就是有n个位置,需要送上pie,之后回到起点,这就是旅行商变形后的问题,其实一个点会经过很多次,但是核心还是遍历所有的点.我们用floyd求出相互之间的最短路径.样例的路径为0->1->2->3->0,他们之间的最短路为
1 1 3 3 为 8.
我们状态压缩来表示一个点是否走过.dp[s][i]表示,已经走过了s中的点,最后一个经过的点为 i .s为二进制表示的一个状态,当s全为1的时候表示全部走完.遍历状态的时候,我们枚举每一种状态,dp[s][i]可以从未含有i的dp[s`][j]中转移,转移过程需要加上j到i的距离.
参考题解

代码实现

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=25;
const int inf=0x3f3f3f3f;
int map[maxn][maxn];
int n;
int dp[1<<22][maxn];
int main()
{
	while(cin>>n&&n)
	{
		for(int i=0;i<=n;i++)
		{
			for(int j=0;j<=n;j++)
				cin>>map[i][j];
		}
		for(int k=0;k<=n;k++)
			for(int i=0;i<=n;i++)
				for(int j=0;j<=n;j++) 
					map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
		int m=(1<<n)-1;
		for(int s=0;s<=m;s++)
		{
			for(int i=1;i<=n;i++)
			{
				if(s&(1<<i-1))
				{
					if(s==(1<<(i-1)))
						dp[s][i]=map[0][i];
					else
					{
						dp[s][i]=inf;
						for(int j=1;j<=n;j++)
						{
							if(s&(1<<(j-1))&&j!=i)
							{
								dp[s][i]=min(dp[s][i],dp[s-(1<<(i-1))][j]+map[j][i]);
								//从中拿掉i点,从未拥有i的集合中更新
							}
						}
					}
				}
			}
		}
		int ans=inf;
		for(int i=1;i<=n;i++)
			ans=min(ans,dp[m][i]+map[i][0]);//判断回到起点后的总距离
		cout<<ans<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值