3070 Fibonacci 二分

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3459 Accepted: 2426

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

[f[n+1]   f[n]]=[1 1]^n

[f[n]    f[n-1]]      [1 0]

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875
#include<iostream>
#include<cstdio>
using namespace std;
int a[4],b[4];
void binary(int n)
{
   // cout<<n<<".."<<endl;
    if(n==1||n==0)
    {
        //b[3]=1,b[2]=1,b[1]=1,b[0]=0;
        a[3]=1,a[2]=1,a[1]=1,a[0]=0;
        return ;
    }
    else if(n&1)
    {
       // for(int i=3;i>=0;i--) cout<<a[i]<<"..";cout<<endl;
        binary(n/2);
        //for(int i=3;i>=0;i--) cout<<a[i]<<"..";cout<<endl;
        b[3]=(a[3]*a[3]+a[2]*a[1])%10000;
        b[2]=(a[3]*a[2]+a[2]*a[0])%10000;
        b[1]=(a[1]*a[3]+a[0]*a[1])%10000;
        b[0]=(a[1]*a[2]+a[0]*a[0])%10000;
        for(int i=3;i>=0;i--) a[i]=b[i];
        //for(int i=3;i>=0;i--) cout<<a[i]<<"..";cout<<endl;
        b[3]=(a[3]+a[2])%10000;
        b[2]=a[3];
        b[1]=(a[1]+a[0])%10000;
        b[0]=a[1];
        for(int i=3;i>=0;i--) a[i]=b[i];
       // for(int i=3;i>=0;i--)  cout<<a[i]<<"..";cout<<endl;
    }
    else
    {
        binary(n/2);
        b[3]=(a[3]*a[3]+a[2]*a[1])%10000;
        b[2]=(a[3]*a[2]+a[2]*a[0])%10000;
        b[1]=(a[1]*a[3]+a[0]*a[1])%10000;
        b[0]=(a[1]*a[2]+a[0]*a[0])%10000;
        for(int i=3;i>=0;i--) a[i]=b[i];
    }
}         
int main()
{
    long long n;
    while(cin>>n)
    {
        if(n==-1) break;
        if(n==0) {printf("0/n");continue;}
       // a[3]=1,a[2]=1,a[1]=1,a[0]=0;
        binary(n-1);
        printf("%d/n",a[3]);
    }
    return 0;
}       
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值