3233 Matrix Power Series 求矩阵 S = A + A2 + A3 + … + Ak 二分 矩阵模板

Matrix Power Series
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 6040 Accepted: 2579

Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4
0 1
1 1

Sample Output

1 2
2 3

Source

POJ Monthly--2007.06.03, Huang, Jinsong
#include<iostream>
#include<cstdio>
using namespace std;
const int  maxn=32;
int m,n,k;
struct Matrix
{
    int m[maxn][maxn];
} mat;
Matrix operator * (const Matrix & m1,const Matrix & m2)
{
    Matrix res;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            res.m[i][j]=0;
            for(int k=0;k<n;k++)
            {
                res.m[i][j]+=m1.m[i][k]*m2.m[k][j];
            }
            res.m[i][j]%=m;//只在这道题中有用
        }
    return res;
}
Matrix operator +(const Matrix & m1,const Matrix & m2)
{
    Matrix res;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
            res.m[i][j]=(m1.m[i][j]+m2.m[i][j])%m;
    return res;
}
Matrix power(int l)
{
   if(l==1) return mat;
    else
    {
        Matrix res;
        Matrix tmp=power(l/2);
        res=tmp*tmp;
        if(l&1) res=res*mat;
        return res;
    }
}
Matrix solve(int k)
{
    Matrix res;
    if(k==1) return mat;
    else
    {
        res=solve(k/2);
        if(k&1)  //k是奇数
        {
            Matrix tmp=power(k/2+1);
            res=tmp*res+res+tmp;
        }
        else //k是偶数
        {
            res=power(k/2)*res+res;
        }
        return res;
    }
}
void print(const Matrix & m)
{
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n-1;j++)
            printf("%d ",m.m[i][j]);
        printf("%d/n",m.m[i][n-1]);
    }
}
int main()
{
    scanf("%d%d%d",&n,&k,&m);
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            scanf("%d",&mat.m[i][j]);
            mat.m[i][j]%=m;
        }
    print(solve(k));
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值