HDU-1542 Atlantis(线段树扫描线)

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 < =x1 < x2 < =100000;0 < =y1 < y2 < =100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
Sample Input
2
10 10 20 20
15 15 25 25.5
0
Sample Output
Test case #1
Total explored area: 180.00

题意:给出n个矩形,给出每个矩形最左下角的坐标和最右上角的坐标,计算所有矩形所覆盖的面积。输入0结束程序,若被多个矩形多次覆盖则按一次面积计算。

线段树扫描线模板题

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e3+10;
struct edge
{
    double x,yu,yd;
    int flag;
    edge() {};
    edge(double a,double b,double c,int d)
    {
        x=a;
        yd=b;
        yu=c;
        flag=d;
    }
    bool operator <(const edge &a)
    {
        return x<a.x;
    }
} a[maxn];
int n;
struct node
{
    int l,r,cnt;
    double len,ren,dis;
} tre[maxn<<2];
double y[maxn];
void build(int l,int r,int rt)
{
    tre[rt].l=l;
    tre[rt].r=r;
    tre[rt].len=y[l];
    tre[rt].ren=y[r];
    tre[rt].cnt=0;
    if(tre[rt].l+1==tre[rt].r) return;
    int mid=(l+r)>>1;
    build(l,mid,rt<<1);
    build(mid,r,rt<<1|1);
}
void cal_dis(int rt)
{
    if(tre[rt].cnt>0) tre[rt].dis=tre[rt].ren-tre[rt].len;///若覆盖计数大于0,该区间的覆盖面积为区间长度
    else if(tre[rt].r-tre[rt].l==1)  tre[rt].dis=0;///叶子节点
    else tre[rt].dis=tre[rt<<1].dis+tre[rt<<1|1].dis;///不是叶子节点,通过向上传递,两个子节点的dis之和即更大区间的dis
    return ;
}
void update(edge line,int rt)
{
    if(tre[rt].len==line.yd&&tre[rt].ren==line.yu)
    {
        tre[rt].cnt+=line.flag;
        cal_dis(rt);
        return ;
    }
    if(line.yu<=tre[rt<<1].ren) update(line,rt<<1);
    else if(line.yd>=tre[rt<<1|1].len) update(line,rt<<1|1);
    else
    {
        edge tmp=line;
        tmp.yu=tre[rt<<1].ren;
        update(tmp,rt<<1);
        tmp=line;
        tmp.yd=tre[rt<<1|1].len;
        update(tmp,rt<<1|1);
    }
    cal_dis(rt);
    return;
}
int main()
{
    double x1,y1,x2,y2;
    int cas=1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        int num=1;
        if(n==0)break;
        for(int i=1; i<=n; i++)
        {
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            y[num]=y1;
            a[num++]=edge(x1,y1,y2,1);
            y[num]=y2;
            a[num++]=edge(x2,y1,y2,-1);
        }
        double ans=0;
        sort(a+1,a+num);
        sort(y+1,y+num);
        build(1,num-1,1);
        update(a[1],1);
        for(int i=2; i<num; i++)
        {
            ans+=tre[1].dis*(a[i].x-a[i-1].x);
            update(a[i],1);
        }
        printf("Test case #%d\n",cas++);
        printf("Total explored area: %.2f\n\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值