PAT A1065 A+B and C (64bit) (20分)

PAT A1065 A+B and C 64bit 20分

原题

Given three integers A, B and C in [−2​63​​ ,2​63​ ], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

大体思路

就是64bit的数相加比大小,重点是溢出问题

思路

long long型的数的最大值为263-1,最小值为-263
因此当A和B都是最大值时,它们的和为264-2,此时它们的和输出为负,但显然A+B>C
当A和B都是最小值时,它们的和为-264,此时它们的和的输出为正,但显然A+B<C
因此要先排除以上两种情况后再判断A+B和C的大小
注意!!这里的a、b、c如果用cin输入就会出错,而用scanf输入就会正确

代码

#include <iostream>
using namespace std;
#include <cstdio>

int main() {
	int n;
	cin >> n;
	for (int i = 1; i <= n; i++) {
		long long a, b, c, sum;
		scanf("%lld%lld%lld", &a, &b, &c);
		//cin >> a >> b >> c;
		cout << "Case #" << i << ": ";
		sum = a + b;
		if (a > 0 && b > 0 && sum < 0)
			cout << "true" << endl;
		else if (a < 0 && b < 0 && sum >= 0)
			cout << "false" << endl;
		else if (sum > c)
			cout << "true" << endl;
		else
			cout << "false" << endl;
	}
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值