HDOJ 5776 树状数组

19 篇文章 0 订阅
16 篇文章 0 订阅

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1372    Accepted Submission(s): 572


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 , 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO

当n>=m 时一定yes

当n<m时候若pre[1...i]%m==pre[i...j]%m或者pre[1...i]%m==0    (1<=i<j<=n)

#include"iostream"
#include"cstdio"
using namespace std;
const int maxn=100000*4;
int upper;
int tree[maxn];
int visit[maxn];

int lowbit(int x)
{
    return x&(-x);
}


void init()
{
    upper=0;
    memset(tree,0,sizeof(tree));
}


void update(int r,int x)
{
    while(r<=upper){tree[r]+=x;r+=lowbit(r);}
}

int sum(int r)
{
    __int64 res=0;
    while(r)
    {
        res+=tree[r];
        r-=lowbit(r);
    }
    return res;
}


int main()
{
    
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);

        memset(visit,0,sizeof(visit));
        init();
        upper=n;

        /*cout<<"n:"<<n<<endl;*/


        int flag=0;
        for(int i=1;i<=n;i++)
        {
            int a;
            scanf("%d",&a);
            update(i,a);
            
            int mod=sum(i)%m;
            if(!mod)
                flag=1;
            if(!visit[mod])
                visit[mod]=1;
            else
                flag=1;
        }
        if(n>=m)
        {
            printf("YES\n");
        }
        else
        {
            /*for(int i=1;i<=n;i++)
                cout<<sum(i)<<endl;*/
            if(flag)
                printf("YES\n");
            else
                printf("NO\n");
        }

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值