Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 217848 Accepted Submission(s): 51419
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
Author
Ignatius.L
用慕课上陈越姥姥讲的方法,用max来记录最大子串和,用ans来记录当前子串和,其他位置信息啊、长度什么都好说。从输入的时候就对ans赋值,每次新输入一个值的时候判断ans是否小于零,若小于,那么ans代表的串对我们求最大串是没有贡献的,直接舍弃他,令ans等于当前位置数。若ans大等于0,那么就将ans加上当前这个数字。
每每读取一个数时都要令max=(max,ans)
下面代码:
#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <map>
using namespace std;
const int maxn = 100005;
int save[maxn];
int main(){
int t,i;
scanf("%d",&t);
int rnd=1;
while(t--){
int n;
int ans=0,max_i=0,max_n = -1000000,position=1,len=0;
scanf("%d",&n);
//scanf("%d",&save[1]);
//ans = save[1];
for(i=1;i<=n;i++){
scanf("%d",&save[i]);
if(ans<0){
ans =save[i];
max_i=1;
}else{
ans += save[i];
max_i++;
}
if(ans>max_n){
max_n=ans;
len = max_i;
position = i;
}
}
printf("Case %d:\n%d %d %d\n",rnd,max_n,position-len+1,position);
if(t>0){
printf("\n");
}
rnd++;
}
return 0;
}