hdu1003 Max Sum(动态规划)

                                                           Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 217253    Accepted Submission(s): 51248


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

题意:给你有n个数的序列,找到他的一个最大的子序列,输出他们的和,开始位置和结束位置

典型的dp题,一个数,它可能是一个子序列的终点或起点,用dp数组保存

动态转移方程dp[i]=max(a[i]+dp[i-1],a[i])

然后确定最大值dp[i]的位置,然后往前找,当dp[k]<0时结束,因为当dp[k]<0时,也就是从它开始的子序列是最大的

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 100005
using namespace std;
int main()
{
    int t,i,a[N],dp[N];
    int flag=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,en,maxdp;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
          scanf("%d",&a[i]);
        dp[0]=0;
        for(i=1;i<=n;i++)        
            dp[i]=max(a[i]+dp[i-1],a[i]);
        maxdp=-1001;
        for(i=1;i<=n;i++)
           if(maxdp<dp[i])    
           {
               maxdp=dp[i];
               en=i;              
           }                          
        int ste=en; 
        for(i=en-1;i>=1;i--)
        {
            if(dp[i]>=0)
            {
                 ste=i; 
			                            
            }
            else break;
        }            
        printf("Case %d:\n",flag++);
        printf("%d %d %d\n",maxdp,ste,en);  
        if(t)  
           printf("\n");  
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值