poj3984 迷宫问题 BFS入门 TWT Tokyo Olympic 2combo-4

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16477 Accepted: 9826

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source

首先。。。这题数据机器水。。。。直接打答案都能过。。。。奶奶的。。。一点成就感都没有

本来想dfs和bfs都打一打的,不过这个路径处理和题水的程度实在是让人不想打。。。。

书上的的题目又没有题可以在线叫,权当bfs练手了吧

下面代码



/*
 ━━━━━┒
 ┓┏┓┏┓┃μ'sic foever!!
 ┛┗┛┗┛┃\○/
 ┓┏┓┏┓┃ /
 ┛┗┛┗┛┃ノ)
 ┓┏┓┏┓┃
 ┛┗┛┗┛┃
 ┓┏┓┏┓┃
 ┛┗┛┗┛┃
 ┓┏┓┏┓┃
 ┛┗┛┗┛┃
 ┓┏┓┏┓┃
 ┃┃┃┃┃┃
 ┻┻┻┻┻┻
 */
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
const int maxn=1010;
const int INF=1000000;
struct unit{
	int x,y;
};
struct node{
	int ask;
	int n;
	unit way[100];
}save[5][5];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
int picture[5][5];
int main(){
	int i,j;
	for(i=0;i<5;i++){
		for(j=0;j<5;j++){
			cin>>picture[i][j];
		}
	}
	memset(save,0,sizeof(save));
	for(i=0;i<5;i++){
		for(j=0;j<5;j++){
			save[i][j].ask=INF;
		}
	}
    queue<unit> que;
    unit now;
    now.x=0;
    now.y=0;
    que.push(now);
    save[0][0].ask=0;
    while(que.size()){
    	unit t=que.front();
    	que.pop();
    	if(t.x==4&&t.y==4){
    		break;
		}
		for(i=0;i<4;i++){
			int x_pro=t.x+dx[i];
			int y_pro=t.y+dy[i];
			if(x_pro>=0&&x_pro<5&&y_pro>=0&&y_pro<5&&picture[x_pro][y_pro]!=1&&save[x_pro][y_pro].ask==INF){
				now.x=x_pro;
				now.y=y_pro;
				que.push(now);
				save[x_pro][y_pro].ask=save[t.x][t.y].ask+1;
				save[x_pro][y_pro].n=save[t.x][t.y].n;
				for(int k=0;k<save[t.x][t.y].n;k++){
					save[x_pro][y_pro].way[k]=save[t.x][t.y].way[k];
				}
				save[x_pro][y_pro].way[save[x_pro][y_pro].n]=t;
				save[x_pro][y_pro].n++;
			}
		}
	}
	for(i=0;i<save[4][4].n;i++){
		printf("(%d, %d)\n",save[4][4].way[i].x,save[4][4].way[i].y);
		//cout<<save[4][4].way[i].x<<" "<<save[4][4].way[i].y<<endl;
	}
	printf("(4, 4)\n");
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值