POJ - 3292 Semi-prime H-numbers(水+艾式筛法+打表)

点击打开题目链接

Semi-prime H-numbers
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9457Accepted: 4202

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

题目不难,只是借这个题写一下艾式筛法。

艾式筛法求素数代码(对于每一个素数,它的N倍一定不是素数):

for(int i=2;i<maxn;i++)
{
    if(!vis[i])
    {
        vis[i]=1;
        prime[cnt++]=i;
        for(int j=i*i;j<maxn;j*=i)
            vis[j]=1;
    }
}

附上AC代码:

#include<iostream>

using namespace std;
const int maxn=1000000+5;
int cnt[maxn];
int a;

void is_Hprime()
{
    for(int i=5;i<maxn;i+=4)
    {
        for(int j=5;j<maxn;j+=4)
        {
            if(i*j>maxn)break;
            if(!cnt[i]&&!cnt[j])
            {
                cnt[i*j]=1;
            }
            else cnt[i*j]=-1;
        }
    }
    int num=0;
    for(int i=25;i<maxn;i++)
    {
        if(cnt[i]==1)
            num++;
        cnt[i]=num;
    }
}

int main()
{
    is_Hprime();
    while(cin>>a,a)
        cout<<a<<' '<<cnt[a]<<endl;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值