HDU - 1068 Girls and Boys(最大独立集)

55 篇文章 0 订阅
6 篇文章 0 订阅

点击打开题目链接

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11551    Accepted Submission(s): 5419

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

 
 
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output

 
 
5 2

Source

Recommend

JGShining   |   We have carefully selected several similar problems for you:   1150  1151  1281  1507  1528 

Statistic | Submit | Discuss | Note

二分图的最大独立集问题。

题目大意:找到最大集合使得该集合任意两人没有关系。

思路:①因为没有明确的男女关系,(a,b)和(b,a)相同,所以只有一个集合,最后要cnt/2;

   ②最大独立集=顶点总数-最大匹配数

匈牙利算法

附上AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
const int maxn=1000;
int G[maxn][maxn];//邻接矩阵
int used[maxn];//记录V2中的每个点是否被搜索过
int result[maxn];//记录V2中的点匹配的点的编号
int T;
int temp,n;
int m;
int cnt;

int find(int x)
{
    for(int i=0;i<T;i++)
    {
        if(G[x][i]&&!used[i])//如果节点i与x相邻并且未被查找过
        {
            used[i]=1;//标记为已查找
            if(result[i]==-1||find(result[i]))//如果i未在前一个匹配中
            {                                         //或者在前一个匹配中但与从i相邻的节点出发有增广路
               result[i]=x;//记录查找成功记录
               return 1;//返回查找成功
            }
        }
    }
    return 0;
}
int main()
{
    ios::sync_with_stdio(false);
    while(scanf("%d",&T)!=EOF)
    {
        memset(G,0,sizeof(G));
        memset(used,0,sizeof(used));
        memset(result,-1,sizeof(result));
        cnt=0;
        for(int i=1;i<=T;i++)
        {
            scanf("%d: (%d)",&temp,&n);
            for(int j=0;j<n;j++)
            {
                scanf("%d",&m);
                G[temp][m]=1;
            }
        }
        for(int i=0;i<T;i++)
        {
            memset(used,0,sizeof(used));//清空上次搜索标记
            if(find(i))cnt++;//从节点i尝试扩展
        }
        cout<<T-cnt/2<<endl;
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值