HDU - 1087 Super Jumping! Jumping! Jumping!(最大递增子段和)

55 篇文章 0 订阅
11 篇文章 0 订阅

点击打开题目链接

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40697    Accepted Submission(s): 18831

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

 
 
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0

Sample Output

 
 
4 10 3

Author

lcy

Recommend

We have carefully selected several similar problems for you:   1176  1159  1069  2084  1058 

Statistic | Submit | Discuss | Note

题目大意:

给出n及n个数,求最大递增子段的和。

思路:

对于任意val[j],扫描前面小于val[i]的数a[j],找最大的sum[i].

状态方程::sum[j]=max{sum[i]}+a[j],i<j.a[i]<a[j]

附上AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;
const int maxn = 1000 +5;
const int INF = 0x7f7f7f;
int val[maxn], dp[maxn];
int n;
int sum;

int main() {
    ios::sync_with_stdio(false);
    while(cin >> n , n){
        memset(dp, 0, sizeof(dp) );
        for(int i = 1; i <= n; i++)
            cin >> val[i];
        for(int i = 1; i <= n; i++){
            sum = - INF;
            for(int j = 0; j < i; j++){
                if(val[j] < val[i])
                    sum = max(sum, dp[j]);
            }
            dp[i]=sum+val[i];
        }
        for(int i = 0; i <= n; i++){
            if(dp[i] > sum)
                sum = dp[i];
        }
        cout << sum << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值