HDU - Monkey and Banana (最大递增子段和)

55 篇文章 0 订阅
11 篇文章 0 订阅

点击打开题目链接

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16178    Accepted Submission(s): 8606

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

 
 
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0

Sample Output

 
 
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

Source

Recommend

JGShining   |   We have carefully selected several similar problems for you:   1176  1058  1159  2084  1203 

Statistic | Submit | Discuss | Note

题目大意:

给出N种长方体箱子的长,宽,高。求最高堆砌高度。(下面的长方体长与宽均大于上面的才能堆砌)

思路:

首先对于给出的每组长方体改变形式,延伸出所有的长方体。

然后排序,求出每种长方体i之前符合堆砌条件的所有j。比较dp[j]+h[i]的大小,最后遍历一遍求最大即可。

状态方程:dp[i] = max{dp[j]} + h[i]; j<i.

附上AC代码:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>

using namespace std;
const int maxn = 200 + 5;
int dp[maxn];
int n;
int a, b, c;
int tmp, cnt, _max, kase;

struct rec {
    int x, y, z;
    bool operator < (const rec other) {
        return x < other.x || (x == other.x && y < other.y) || (x == other.x && y == other.y && z < other.z);
    }
} rect[maxn];

void input(int a, int b, int c) {
    tmp = a + b + c;
    a = min(a, min(b, c) );
    c = max(c, max(a, b) );
    b = tmp - a - c;
    if(a != b && b != c) {
        rect[cnt].x = a; rect[cnt].y = b; rect[cnt++].z = c;
        rect[cnt].x = b; rect[cnt].y = a; rect[cnt++].z = c;
        rect[cnt].x = a; rect[cnt].y = c; rect[cnt++].z = b;
        rect[cnt].x = c; rect[cnt].y = a; rect[cnt++].z = b;
        rect[cnt].x = b; rect[cnt].y = c; rect [cnt++].z = a;
        rect[cnt].x = c; rect[cnt].y = b; rect [cnt++].z = a;
    }
    else if(b != c) {
        rect[cnt].x = a; rect[cnt].y = b; rect[cnt++].z = c;
        rect[cnt].x = a; rect[cnt].y = c; rect[cnt++].z = b;
        rect[cnt].x = c; rect[cnt].y = a; rect[cnt++].z = b;
    }
    else if(a != b) {
        rect[cnt].x = a; rect[cnt].y = b; rect[cnt++].z = c;
        rect[cnt].x = b; rect[cnt].y = a; rect[cnt++].z = c;
        rect[cnt].x = b; rect[cnt].y = c; rect[cnt++].z = a;
    }
    else {
        rect[cnt].x = a;
        rect[cnt].y = a;
        rect[cnt++].z = a;
    }
}

int main() {
    ios :: sync_with_stdio(false);
    while(cin >> n, n) {
        cnt = 0;
        memset(dp, 0, sizeof(dp) );
        for(int i = 0; i < n; i++){
            cin >> a >> b >> c;
            input(a, b, c);
        }
        sort(rect, rect+ cnt);
        for(int i = 0; i < cnt; i++) {
            _max = 0;
            for(int j = 0; j < i; j++) {
                if(rect[i].x > rect[j].x && rect[i].y > rect[j].y) {
                    _max = max(_max, dp[j]);
                }
            }
            dp[i] = _max + rect[i].z;
        }
        _max = 0;
        for(int i = 0; i < cnt; i++) 
            if(_max < dp[i])
                _max = dp[i];
        cout<<"Case "<<++kase<<": maximum height = "<<_max<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值