Revenge of GCD (枚举+gcd)

Revenge of GCD

 In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y. 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
Sample Input

3
2 3 1
2 3 2
8 16 3

Sample Output

1
-1
2
题意:

求x,y的第k大公因数

分析:

一开始还以为什么很难的题按着算术基本定理想了很久,原来是枚举gcd的因子,fuck?

首先求出最大公因数,然后在枚举出gcd的所有因子排个序就可以了

可以使用vector

注意一开始一开始把1和它本身放入,但是要判断如果它本身就是1不可以放两次!!

然后常规操作,从2开始枚举因子即可 g g 的复杂度,排序log复杂度,求gcd log复杂度

code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b){
    return b ? gcd(b,a%b) : a;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        ll x,y,k;
        scanf("%lld%lld%lld",&x,&y,&k);
        ll g = gcd(x,y);
        vector<ll> ans;
        ans.push_back(1LL);
        if(g != 1)
            ans.push_back(g);
        for(ll i = 2; i * i <= g; i++){
            if(g % i == 0){
                ans.push_back(i);
                if(i * i != g)
                    ans.push_back(g/i);
            }
        }
        sort(ans.begin(),ans.end());
        if(k > ans.size())
            printf("-1\n");
        else
            printf("%lld\n",ans[ans.size()-k]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值