Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19783    Accepted Submission(s): 11888


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16

题意:

        有一个n个整数的排列,这n个整数就是0,1,2,3...n-1这n个数(但不一定按这个顺序给出)。现在先计算一下初始排列的逆序数,然后把第一个元素a1放到an后面去,形成新排列a2 a3 a4...an a1,然后再求这个排列的逆序数。继续执行类似操作(一共要执行n-1次)直到产生排列an a1 a2...an-1为止。计算上述所有排列的逆序数,输出最小逆序数。

分析:

        首先对于输入的排列0到n-1,我们把他们都+1变成1到n的数。然后用标记法来计算出初始排列的逆序数为X。

        然后假设当前a[1]的值为5,那么将5换到an后面我们将得到新排列的逆序数是多少呢?因为一共有4个数比5大,n-5个数比5小,所以新排列的逆序数为:n-(n-5)+4。(想想为什么

        最终我们可以通过上述方式轻松算出之后的n-2次变换产生的新数列的逆序数。

/*
例如要求x的逆序数只需要访问(x+1,n)段有多少个数,
就是x的逆序数。还有就是求最小逆序数的时候有个巧妙的想法,
当把x放入数组的后面,
此时的逆序数应该为x没放入最后面之前的逆序总数加上(n-x)再减去(x+1);
sum = sum+n-x[i]-x[i]-1。
*/

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int MAXN =1e5+10;
int bit[MAXN];
int n;

void add(int i,int x){
	while(i<=n){
		bit[i]+=x;
		i+=i&-i;
	}
}
int sum(int i){
	int s=0;
	while(i>0){
		s+=bit[i];
		i-=i&-i;
	}
	
	return s;
}
int main(){
	
	while(scanf("%d",&n)!=EOF){
		int a[n];
		
		long long tmp=0;
		memset(bit,0,sizeof(bit));
		for(int i=1;i<=n;i++)
		{
		scanf("%d",&a[i]);	
		a[i]++;
		add(a[i],1);
		tmp+=i-sum(a[i]);		
		}
	//	printf("%d\n",tmp);
		long long ans=tmp;
		
		for(int i=1;i<=n;i++)
		{
			tmp=tmp+(n-a[i])-(a[i]-1);
			ans=min(ans,tmp);
		}
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值