ZOJ-1078-Palindrom Numbers

Statement of the Problem

We say that a number is a palindrom if it is the sane when read from left to right or from right to left. For example, the number 75457 is a palindrom.

Of course, the property depends on the basis in which is number is represented. The number 17 is not a palindrom in base 10, but its representation in base 2 (10001) is a palindrom.

The objective of this problem is to verify if a set of given numbers are palindroms in any basis from 2 to 16.

Input Format

Several integer numbers comprise the input. Each number 0 < n < 50000 is given in decimal basis in a separate line. The input ends with a zero.

Output Format

Your program must print the message Number i is palindrom in basis where I is the given number, followed by the basis where the representation of the number is a palindrom. If the number is not a palindrom in any basis between 2 and 16, your program must print the message Number i is not palindrom.

Sample Input

17
19
0

Sample Output

Number 17 is palindrom in basis 2 4 16
Number 19 is not a palindrom


#include <iostream>
using namespace std;

void change_base_palindrom(int num)
{
    int i,j,number[100]={0},base,judge,base_num[17]={0},n,older=0;
    for(base=2;base<17;base++)
    {
        n=num;
        judge=0;

        for(i=0;n!=0;i++)
        {
            number[i]=n%base;
            n/=base;
        }

        for(j=0;j<i/2;j++)
            if(number[j]!=number[i-j-1])
            {
                judge=1;
                break;
            }

        if(judge==0)
        {
            base_num[base]=1;
            older+=1;
        }

    }
    if(older==0)
        cout<<"Number "<<num<<" is not a palindrom"<<endl;
    else
        {
            cout<<"Number "<<num<<" is palindrom in basis";
            for(i=2;i<17;i++)
                if(base_num[i]==1)
                cout<<' '<<i;
            cout<<endl;
        }



}
int main()
{
    /*int n;
    cin>>n;
    while(n)
    {
        if(n>0&&n<50000)
            change_base_palindrom(n);
        cin>>n;
    }*/
    int a[100],i=0,j;
    cin>>a[i];
    while(a[i])
    {
        i+=1;
        cin>>a[i];
    }
    for(j=0;j<i;j++)
        change_base_palindrom(a[j]);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值