NYOJ-ACM-A+B Problem II

描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
来源
经典题目
上传者
张云聪

思路:

题目大意是首先第一行输入一个数字,表示有几组数据,接着输入相对应组数的数据,每组两个数字代表A 和B。然后计算A+B的值,并按格式输出。

这道题考查了大数相加,这里我用的是BigInteger这个函数,还可以模拟数学除法。具体看代码即可。


代码:

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		int a = sc.nextInt();
		BigInteger[][] bi = new BigInteger[a][2];//定义大数数组
		for(int i=0;i<a;i++){
			for(int j=0;j<2;j++){
				bi[i][j] = sc.nextBigInteger();
			}
		}
		for(int i=0;i<a;i++){
			System.out.println("Case "+(i+1)+":");
			System.out.println(bi[i][0]+" + "+bi[i][1]+" = "+bi[i][0].add(bi[i][1]));//求取结果输出
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值