ACM-大数之A + B Problem II——hdu1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 189306    Accepted Submission(s): 36174


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110 大数处理中的加法运算
#include <iostream>
#include <cstring>
using namespace std;
char str[10001],str1[10001],str2[10001];
int len1,len2;

bool add(char str1[],char str2[])
{
	int i,j;
	
	
	if(len1>=len2)
	{
		for(i=len1-1,j=len2-1;j>=0;--i,--j)
		{
			str[i]=str1[i]+str2[j]-48;
			if(str[i]>57)
			{
				str[i]-=10;
				str1[i-1]+=1;
			}
		}
		for(j=i;j>=0;--j,--i)
			str[i]=str1[j];
		
		return 1;
	}
	else
	{
		for(i=len1-1,j=len2-1;i>=0 && j>=0;--i,--j)
		{
			str[j]=str1[i]+str2[j]-48;
			if(str[j]>57)
			{
				str[j]-=10;
				str2[j-1]+=1;
			}
		}
		for(i=j;i>=0;--i,--j)
			str[j]=str2[i];
		
		return 0;
	}
	
}


int main()
{	
	int num,n,i;
	cin>>n;
	for(num=1;num<=n;++num)
	{
		cin>>str1>>str2;	
		len1=strlen(str1);
		len2=strlen(str2);

		cout<<"Case "<<num<<":"<<endl;
		for(i=0;i<len1;++i)
			cout<<str1[i];
		cout<<" + ";
		for(i=0;i<len2;++i)
			cout<<str2[i];
		cout<<" = ";
		
		if(add(str1,str2))
		{
			for(i=0;i<len1;++i)
				cout<<str[i];
		}
		else
		{
			for(i=0;i<len2;++i)
				cout<<str[i];
		}
		
		cout<<endl;
		if(num==n)	break;
		cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值