ACM刷题之HDU————A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3109 Accepted Submission(s): 1155
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output

            For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 

一道高精度算法的题目,要自己手动模拟加法运算。
写完记得测试下998+2 之类的进位数据,有可能错在这里。
下面是ac代码(有点长,其实可以再缩的)

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
using namespace std;
char a[5000];
char b[5000];
int  sum[20000];
int q[5000];
int w[5000]; 
int main()
{
	int i,j,num,zu,zu1,len1,len2,c,x;
	scanf("%d",&zu);
	for(zu1=1;zu1<=zu;zu1++)
	{
		scanf("%s",a);
		scanf("%s",b);
		len1=strlen(a);
		for(i=0;i<len1;i++)
		q[i]=a[i]-'0';
		len2=strlen(b);
		for(i=0;i<len2;i++)
		w[i]=b[i]-'0';
		i=len1;
		j=len2;
		x=0;
		memset(sum,0,sizeof(sum));
		if(len1<=len2)
		{
			j--;
			x=0;
			c=0;
			for(i=i-1;i>=0;i--,j--)
			{
				sum[x]=(q[i]+w[j]+c)%10;
				c=(q[i]+w[j]+c)/10;
				x++;
			}
			for(;j>=0;j--)
			{
				sum[x]=(w[j]+c)%10;
				c=(w[j]+c)/10;
				x++;
			}
			if(c>0)
			{
				sum[x]=c;
			printf("Case %d:\n",zu1);
			printf("%s + %s = ",a,b);
			for(x=x;x>0;x--)
			printf("%d",sum[x]);
			printf("%d\n",sum[0]);
			if(zu1<zu)
			printf("\n");
			continue;
			}
			printf("Case %d:\n",zu1);
			printf("%s + %s = ",a,b);
			for(x=x-1;x>0;x--)
			printf("%d",sum[x]);
			printf("%d\n",sum[0]);
			if(zu1<zu)
			printf("\n");
		}
		else
		{
			i--;
			x=0;
			c=0;
			for(j=j-1;j>=0;i--,j--)
			{
				sum[x]=(q[i]+w[j]+c)%10;
				c=(q[i]+w[j]+c)/10;
				x++;
			}
			for(;i>=0;i--)
			{
				sum[x]=(q[i]+c)%10;
				c=(q[i]+c)/10;
				x++;
			}
			if(c>0)
			{
				sum[x]=c;
				printf("Case %d:\n",zu1);
				printf("%s + %s = ",a,b);
				for(x=x;x>0;x--)
				printf("%d",sum[x]);
				printf("%d\n",sum[0]);
				if(zu1<zu)
				printf("\n");
				continue;
			}
			printf("Case %d:\n",zu1);
			printf("%s + %s = ",a,b);
			for(x=x-1;x>0;x--)
			printf("%d",sum[x]);
			printf("%d\n",sum[0]);
			if(zu1<zu)
			printf("\n");
		}	
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值