HDU 1003 max sum

problem description

given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. for example, given(6,-1,5,4,-7),the max sum in this sequence is 6+(-1)+5+4=14

input

the first line of the input contains an integer T(1<=T<=20) which means the number of test cases. then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000)

output

for each test case, you should output two lines. the first line is “case #:”, #means the number of the test case. the second line contains three integers, the max sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. if there are more than one result, output the first one. output a blank line between two cases.

sample input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

sample output

Case 1:
14 1 4

Case 2:
7 1 6

code

#include<stdio.h>
int main()
{
    int dp[100005];
    int t,k;
    while(scanf("%d",&t)!=EOF)
    {
        for(k=1;k<=t;k++)
        {
            int i,n,start=1,ft=1,lt=1;
            scanf("%d",&n);
            for(i=1;i<=n;i++)
                scanf("%d",&dp[i]);
            int max=dp[1];
            for(i=2;i<=n;i++)
            {
                if(dp[i-1]>=0)dp[i]+=dp[i-1];else start=i;
                if(dp[i]>max){max=dp[i];ft=start;lt=i;}
            }
            if(k>1)printf("\n");
            printf("Case %d:\n%d %d %d\n",k,max,ft,lt);
        }

    }
    return 0;
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值