【hackerrank】-Day 8: Dictionaries and Maps

24 篇文章 0 订阅
24 篇文章 0 订阅

30-dictionaries-and-maps
注意:下面的def定义函数想法挺好,但是实际并不是太好,当phonebook的数量过多时,查询时间就会因重复调用函数多次而 浪费很多时间,最终导致在hackerrank网页执行超时!可以采用直接处理的方法,来规避调用函数带来的时间开销!


Objective
Today, we’re learning about Key-Value pair mappings using a Map or Dictionary data structure. Check out the Tutorial tab for learning materials and an instructional video!

Task
Given names and phone numbers, assemble a phone book that maps friends’ names to their respective phone numbers. You will then be given an unknown number of names to query your phone book for. For each queried, print the associated entry from your phone book on a new line in the form name=phoneNumber; if an entry for is not found, print Not found instead.

Note: Your phone book should be a Dictionary/Map/HashMap data structure.

Input Format

The first line contains an integer, , denoting the number of entries in the phone book.
Each of the subsequent lines describes an entry in the form of space-separated values on a single line. The first value is a friend’s name, and the second value is an -digit phone number.

After the lines of phone book entries, there are an unknown number of lines of queries. Each line (query) contains a to look up, and you must continue reading lines until there is no more input.

Note: Names consist of lowercase English alphabetic letters and are first names only.

Constraints

Output Format

On a new line for each query, print Not found if the name has no corresponding entry in the phone book; otherwise, print the full and in the format name=phoneNumber.

Sample Input

3
sam 99912222
tom 11122222
harry 12299933
sam
edward
harry
Sample Output

sam=99912222
Not found
harry=12299933
Explanation

We add the following (Key,Value) pairs to our map so it looks like this:

We then process each query and print key=value if the queried is found in the map; otherwise, we print Not found.

Query 0: sam
Sam is one of the keys in our dictionary, so we print sam=99912222.

Query 1: edward
Edward is not one of the keys in our dictionary, so we print Not found.

Query 2: harry
Harry is one of the keys in our dictionary, so we print harry=12299933.


Current Buffer (saved locally, editable)

'''
def addPhoneBook(info):
    tup = tuple(info.split(' '))
    return tup

def selectPhoneBook(name, phoneBook):
    if name == '' or len(phoneBook) == 0:
        return 'name or phoneBook is null.'


    ## the first try: tuple (key,value) is not very good!
    # phoneBook_tmp = {}
    # i = 0
    # for ii in range(len(phoneBook)):
    #     tup = phoneBook[ii]
    #     # print(tup)
    #     if name == tup[0]:
    #         phoneBook_tmp[i] = tup
    #         print("%s=%s" %(tup[0],tup[1]))
    #     i += 1
    # if len(phoneBook_tmp) == 0:
    #     print('Not found')
    ## the first try: finish!
    ## the second try: dict {"key":"value"}
    if name in phoneBook:
        print("%s=%s" %(name,phoneBook[name]))
    else:
        print('Not found')
    ## the second try: finish!

ll = int(input())
## the first try
# phoneBook = {}
## the second try
phoneBook_list = []
for num in range(0, ll):
    ## the first try
    # phoneBook[num] = addPhoneBook(input())
    ## the second try
    phoneBook_list.append(addPhoneBook(input()))
for num in range(0, ll):
    ## the first try
    # selectPhoneBook(input(), phoneBook)
    ## the second try
    selectPhoneBook(input(), dict(phoneBook_list))
'''
## the best way!
ll = int(input())
phoneBook = {}
for num in range(0, ll):
    tup = tuple(input().split(' '))
    phoneBook[tup[0]] = tup[1]
for num in range(0, ll):
    name = input()
    if name in phoneBook:
        print("%s=%s" %(name,phoneBook[name]))
    else:
        print('Not found')

Congratulations!

You have passed the sample test cases. Click the submit button to run your code against all the test cases.

Testcase 0
Input (stdin)
3
sam 99912222
tom 11122222
harry 12299933
sam
edward
harry
Your Output (stdout)
sam=99912222
Not found
harry=12299933
Expected Output
sam=99912222
Not found
harry=12299933

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值