hackerrank>Dashboard>C++>STL> Maps-STL

Maps are a part of the C++ STL.Maps are associative containers that store elements formed by a combination of a key value and a mapped value, following a specific order.The mainly used member functions of maps are:

  • Map Template:

    std::map <key_type, data_type>
    
  • Declaration:

    map<string,int>m; //Creates a map m where key_type is of type string and data_type is of type int.
    
  • Size:

    int length=m.size(); //Gives the size of the map.
    
  • Insert:

    m.insert(make_pair("hello",9)); //Here the pair is inserted into the map where the key is "hello" and the value associated with it is 9.
    
  • Erasing an element:

    m.erase(val); //Erases the pair from the map where the key_type is val.
    
  • Finding an element:

    map<string,int>::iterator itr=m.find(val); //Gives the iterator to the element val if it is found otherwise returns m.end() .
    Ex: map<string,int>::iterator itr=m.find("Maps"); //If Maps is not present as the key value then itr==m.end().
    
  • Accessing the value stored in the key:

    To get the value stored of the key "MAPS" we can do m["MAPS"] or we can get the iterator using the find function and then by itr->second we can access the value.
    

To know more about maps click Here.

You are appointed as the assistant to a teacher in a school and she is correcting the answer sheets of the students.Each student can have multiple answer sheets.So the teacher has queries:

:Add the marks to the student whose name is .

: Erase the marks of the students whose name is .

: Print the marks of the students whose name is . (If didn't get any marks print .)

Input Format

The first line of the input contains where is the number of queries. The next lines contain query each.The first integer, of each query is the type of the query.If query is of type , it consists of one string and an integer and where is the name of the student and is the marks of the student.If query is of type or ,it consists of a single string where is the name of the student.

Constraints

Output Format

For queries of type print the marks of the given student.

Sample Input

7
1 Jesse 20
1 Jess 12
1 Jess 18
3 Jess
3 Jesse
2 Jess
3 Jess

Sample Output

30
20
0


1.增加分数,2.分数为0,3.输出分数


#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#define MAX 1e9+8
using namespace std;
int main()
{
    int N;
    while(~scanf("%d",&N))
    {
        map<string,int>mymap;
        int n;
        string s;
        while(N--)
        {
            cin>>n>>s;
               if(n==2)
               mymap.erase(s);
            if(n==3)
                cout<<mymap[s]<<endl;
            if(n==1)
            {
                int m;
                cin>>m;
                mymap[s]+=m;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值