http://poj.org/problem?id=2386
Lake Counting
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 14434 | Accepted: 7297 |
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12 W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source
USACO 2004 November
#include<stdio.h>
#include<string.h>
int mat[110][110];
int vis[110][110];
void dfs(int x,int y)
{
if(vis[x][y]||!mat[x][y])
return ;
vis[x][y]=1;
dfs(x-1,y-1);dfs(x-1,y);dfs(x-1,y+1);
dfs(x,y-1); dfs(x,y+1);
dfs(x+1,y-1);dfs(x+1,y);dfs(x+1,y+1);
}
int main()
{
int n,m;
while(scanf("%d %d",&m,&n)!=EOF)
{
if(m==0&&n==0)
break;
int i,j;
char s[110];
memset(mat,0,sizeof(mat));
memset(vis,0,sizeof(vis));
for(i=0;i<m;i++)
{ scanf("%s",s);
for(j=0;j<n;j++)
{
if(s[j]=='W')
mat[i+1][j+1]=1;
else
mat[i+1][j+1]=0;
}
}
int count=0;
for(i=1;i<=m;i++)
{
for(j=1;j<=n;j++)
{
if(!vis[i][j]&&mat[i][j])
{
count++;
dfs(i,j);
}
}
}
printf("%d\n",count);
}
return 0;
}
1
#include<string.h>
int mat[110][110];
int vis[110][110];
void dfs(int x,int y)
{
}
int main()
{
}