D - Find The Multiple POJ - 1426 ——DFS || BFS

18 篇文章 0 订阅
9 篇文章 0 订阅

Think:
1变量存储数值越界问题
2递归函数得到优解不再继续遍历问题

D - Find The Multiple POJ - 1426

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits. 

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

以下为Accepted代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

int flag;///标记已经找到优解
void DFS(int dig, long long m, int n);

int main(){
    int dig, n;///dig变量控制位数不越界
    while(scanf("%d", &n) && n){
        dig = 1, flag = 0;
        DFS(dig, 1, n);
    }
    return 0;
}
void DFS(int dig, long long m, int n){
    if(flag || dig > 19)
        return;
    if(m % n == 0){
        flag = 1;
        printf("%lld\n", m);
        return;
    }
    else {
        DFS(dig+1, m*10, n);
        DFS(dig+1, m*10+1, n);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值