POJ2386(DFS)

POJ2386(DFS)


Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
题意

八连通的’W’为一片水洼,问总共有多少片水洼。

思路

深度优先搜索(DFS)

代码
import java.util.Scanner;

public class LakeCounting {

    int[][] map = new int[105][105];

    int[] xs = {-1, 0, 1, -1, 0, 1, -1, 0, 1};
    int[] ys = {-1, -1, -1, 0, 0, 0, 1, 1, 1};

    int count = 0;

    public void dfs(int x, int y) {
        if (this.map[x][y] == 1) {
            this.map[x][y] = 0;
        }

        for (int i = 0; i < this.xs.length; i++) {
            if (this.map[x + xs[i]][y + ys[i]] == 1) {
                dfs(x + xs[i], y + ys[i]);
            }
        }

    }

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        LakeCounting lc = new LakeCounting();
        int n = sc.nextInt();
        int m = sc.nextInt();
        for (int i = 1; i <= n; i++) {
            String str = sc.next();
            for (int j = 1; j <= m; j++) {
                if (str.charAt(j - 1) == 'W') {
                    lc.map[i][j] = 1;
                }
            }
        }
        sc.close();

        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= m; j++) {
                if (lc.map[i][j] == 1) {
                    lc.count++;
                    lc.dfs(i,j);
                }
            }
        }
        System.out.println(lc.count);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值