二维RMQ模板题

Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)

Input

There are multiple test cases. 

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer. 

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question. 

Output

For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.

Sample Input

4 4
4 4 10 7
2 13 9 11
5 7 8 20
13 20 8 2
4
1 1 4 4
1 1 3 3
1 3 3 4
1 1 1 1

Sample Output

20 no
13 no
20 yes
4 yes
#include<bits/stdc++.h>
using namespace std;
int MAX(int a,int b)
{
	return a>b?a:b;
}
int dp[306][306][9][9];
int mapp[306][306];
int n,m;
void init()
{
	int i,j,k,u;
	for(i=0;i<=(int)(log(n*1.0)/log(2.0));++i)
	{
		for(j=0;j<=(int)(log(m*1.0)/log(2.0));++j)
		{
			if(i+j)
			{
				for(k=1;k<=n-(1<<i)+1;++k)
				{
					for(u=1;u<=m-(1<<j)+1;++u)
					{
						if(i==0)
						{
							dp[k][u][i][j]=MAX(dp[k][u][i][j-1],dp[k][u+(1<<(j-1))][i][j-1]);
						}
						else
						{
							dp[k][u][i][j]=MAX(dp[k][u][i-1][j],dp[k+(1<<(i-1))][u][i-1][j]);
						}
					}
				}
			}
		}
	}
}
int query(int r1,int c1,int r2,int c2)
{
    int k1=log((r2-r1+1)*1.0)/log(2.0);
    int k2=log((c2-c1+1)*1.0)/log(2.0);
    int x=MAX(dp[r1][c1][k1][k2],dp[r2-(1<<k1)+1][c2-(1<<k2)+1][k1][k2]);
    int y=MAX(dp[r1][c2-(1<<k2)+1][k1][k2],dp[r2-(1<<k1)+1][c1][k1][k2]);
    return MAX(x,y);
}
int main()
{
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=m;++j)
			{
				scanf("%d",&mapp[i][j]);
				dp[i][j][0][0]=mapp[i][j];
			}
		}
		init();
		int q,c1,c2,r1,r2;
		scanf("%d",&q);
		while(q--)
		{
			scanf("%d%d%d%d",&c1,&r1,&c2,&r2);
			int ans=query(c1,r1,c2,r2);
			printf("%d ",ans);
			if(ans==mapp[c1][r1]||ans==mapp[c1][r2]||ans==mapp[c2][r1]||ans==mapp[c2][r2])
				printf("yes\n");
			else
			printf("no\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值