【HDU】2888Check Corners(二维RMQ模板题目)

Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3602    Accepted Submission(s): 1291


 

Problem Description

Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)

 

 

Input

There are multiple test cases.

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer.

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner and lower-right corner of the sub-matrix in question.

 

 

Output

For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.

 

 

Sample Input

 

4 4 4 4 10 7 2 13 9 11 5 7 8 20 13 20 8 2 4 1 1 4 4 1 1 3 3 1 3 3 4 1 1 1 1

 

 

Sample Output

 

20 no 13 no 20 yes 4 yes

 

 

Source

2009 Multi-University Training Contest 9 - Host by HIT

 

 

Recommend

gaojie   |   We have carefully selected several similar problems for you:  2889 2887 2886 2890 2885 

 

题目大意:给你一个N*M的矩阵,每个格子中有一个数字,当然这些数字有大有小,现在给出Q个查询,每个查询代表的是一个区间,问你这个区间内的最大值是多少,还有就是后面的,如果最大值在这个区间的四个定点的某一个,那么输出YES不然输出NO

思路:其实是RMQ的一个基础的题目,不过是二维的,当时写的时候忘记把模板上的求最小值的数组去掉MLE了好几发。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=301;
int val[MAXN][MAXN];
//int dmin[MAXN][MAXN][9][9];
int dmax[MAXN][MAXN][9][9];
void initRMQ(int n,int m)//对n*m的矩阵初始化RMQ且矩阵下标从1开始
{
    for(int i=1; i<=n; i++)
        for(int j=1; j<=m; j++)
            dmax[i][j][0][0]=val[i][j];
    for(int ii=0; (1<<ii)<=n; ii++)
        for(int jj=0; (1<<jj)<=m; jj++)
            if(ii+jj)
                for(int i=1; i+(1<<ii)-1<=n; i++)
                    for(int j=1; j+(1<<jj)-1<=m; j++)
                        if(ii)
                        {
                            //dmin[i][j][ii][jj] = min(dmin[i][j][ii-1][jj],dmin[i+(1<<(ii-1))][j][ii-1][jj]);
                            dmax[i][j][ii][jj] = max(dmax[i][j][ii-1][jj],dmax[i+(1<<(ii-1))][j][ii-1][jj]);
                        }
                        else
                        {
                            //dmin[i][j][ii][jj] = min(dmin[i][j][ii][jj-1], dmin[i][j+(1<<(jj-1))][ii][jj-1]);
                            dmax[i][j][ii][jj] = max(dmax[i][j][ii][jj-1], dmax[i][j+(1<<(jj-1))][ii][jj-1]);
                        }
}
int getMax(int x1,int y1,int x2,int y2)//RMQ查询
{
    int k1=0;
    while((1<<(k1+1))<=x2-x1+1)
        k1++;
    int k2=0;
    while((1<<(k2+1))<=y2-y1+1)
        k2++;
    x2 = x2 - (1<<k1)+1;
    y2 = y2 - (1<<k2)+1;
    return max(max(dmax[x1][y1][k1][k2],dmax[x1][y2][k1][k2]),max(dmax[x2][y1][k1][k2],dmax[x2][y2][k1][k2]) );
}
/*int getMin(int x1,int y1,int x2,int y2)//RMQ查询
{
    int k1=0;
    while((1<<(k1+1))<=x2-x1+1)
        k1++;
    int k2=0;
    while((1<<(k2+1))<=y2-y1+1)
        k2++;
    x2 = x2 - (1<<k1)+1;
    y2 = y2 - (1<<k2)+1;
    return min( min(dmin[x1][y1][k1][k2],dmin[x1][y2][k1][k2]),min(dmin[x2][y1][k1][k2],dmin[x2][y2][k1][k2]) );
}*/
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&val[i][j]);
        initRMQ(n,m);
        int q;
        scanf("%d",&q);
        while(q--)
        {
            int x1,y1,x2,y2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);

            int ans=getMax(x1,y1,x2,y2);
            bool ok=false;
            if(val[x1][y1]==ans||val[x1][y2]==ans||val[x2][y1]==ans||val[x2][y2]==ans)
                ok=true;
            if(ok)
                printf("%d %s\n",ans,"yes");
            else
                printf("%d %s\n",ans,"no");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值