作业——HDOJ1339

题目类别——水题

题目描述:

       Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

       Example:
       For n = 24, o = 3 and p = 3.
       Task:
       Write a program which for each data set,reads a positive integer n,computes the odd integer o and the nonnegative integer p such that n = o2^p,writes the result.

输入要求:

      The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

      Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

输出要求:

       The output should consists of exactly d lines, one line for each data set.

       Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

输入样例:

     1

  
  
24

输出样例:

     3  3

【分析】

   任何一个正整数n,都可以表示成一个奇数o与2的p次幂相乘的,如16=1*2^4,24=3*2^3,29=29*2^0。因此,p即为n中2的个数,而o即为除尽这些2后剩余的商值。参考代码如下:

#include<stdio.h>
int main(){
int
d,n;
scanf("%d",&d);
while
(d--){
scanf("%d",&n);
int
count = 0;
while
(n%2==0){
count++;
n=n/2;
}

printf("%d %d",n,count);
printf("\n");
}

return
1;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值