1136 A Delayed Palindrome (20 分)--PAT甲级

1136 A Delayed Palindrome (20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.
Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.
Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

基本思路:用字符串模拟两数相加,判断回文。注意如果输入就是回文数直接输出即可。

c++

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
const int maxn = 100010;

bool judge(string a){
    for(int i = 0;i <= a.size()/2;i++){
        if(a[i] != a[a.size()-1-i]) return false;
    }
    return true;
}

string reversestr(string a){
    string b;
    for(int i=0;i<a.size();i++){
        b = a[i] + b;
    }
    return b;
}

string add(string a){
    string c;
    int carry = 0;
    for(int i = 0;i < a.size();i++){
        int x = a[i] - '0';
        int y = a[a.size()-1-i] - '0';
        int res = x + y + carry;
        carry = res/10;
        char n = res % 10 + '0';
        c = n + c;
    }
    if(carry == 1) c = '1' + c;
    return c;
}


int main()
{
    string str;
    cin>>str;
    int cnt=10;
    bool flag=false;
    if(judge(str)) {
        cout<<str<<" is a palindromic number."<<endl;
        flag=true;
    }
    else{
        while(cnt--){
            string temp=add(str);
            cout<<str<<" + "<<reversestr(str)<<" = "<<temp<<endl;
            if(judge(temp)) {
                cout<<temp<<" is a palindromic number."<<endl;
                flag=true;
                break;
            }
            str=temp;
        }
    }
    if(!flag) cout<<"Not found in 10 iterations."<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值