Chinese Zodiac (水题)

The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig. 
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them. 
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 22 years. But if the signs of the couple is the same, the answer should be 1212 years.

Input

The first line of input contains an integer T (1≤T≤1000)T (1≤T≤1000) indicating the number of test cases. 
For each test case a line of two strings describes the signs of Victoria and her husband.

Output

For each test case output an integer in a line.

Sample Input

3
ox rooster
rooster ox
dragon dragon

Sample Output

8
4
12

题解:感觉用map更好,但是我STL玩的还是不是特别好,就用二维字符数组代替了

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<map>

using namespace std;


int main()
{
   char a[12][15]={"rat","ox","tiger","rabbit","dragon","snake","horse","sheep","monkey","rooster","dog","pig"};
   int n;
   cin>>n;
   char s1[15],s2[15];
   int k1,k2;
   for(int t=0;t<n;t++)
   {
   	
   	  scanf("%s%s",s1,s2);
   	  for(int j=0;j<12;j++)
   	  {
   	  	if(strcmp(s1,a[j])==0)
   	  	{
   	  	    k1=j;	
		}
		if(strcmp(s2,a[j])==0)
		{
			k2=j;
		}
	  }
	  if(k1==k2)
	  {
	  	printf("12\n");
	  }
	  if(k1<k2)
	  {
	  	printf("%d\n",k2-k1);
	  }
	  if(k1>k2)
	  {
	  	printf("%d\n",12+k2-k1);
	  }
   }
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值