POJ - 3278 -Catch That Cow (BFS)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路:BFS判断注意把vis数组开大点,不然容易WA,

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int N,K;
int vis[500005];
struct node 
{
	int x,y;
	int step;
}start;
queue <node> q;
int bfs()
{
	while(!q.empty())
	{
		q.pop();
	}
	memset(vis,0,sizeof(vis));
	
	vis[start.x]=1;
	q.push(start);
	while(!q.empty())
	{
		node now=q.front();
		if(now.x==K)
		{
			return now.step;
		}
		q.pop();
		for(int t=0;t<3;t++)
		{
			node next = now;
			if(t==0)
			{
			   next.x=next.x+1;	
			}
			if(t==1)
			{
				next.x=next.x-1;
			}
			if(t==2)
			{
				next.x=2*next.x;
			}
			next.step++;
			if(next.x==K)
			{
				return next.step;
			}
			if(next.x>=0&&next.x<=200000&&!vis[next.x])
			{
				vis[next.x]=1;
				q.push(next);
			}
		}
	}
	return 0;
	
}

int main()
{
	cin>>N>>K;
	start.x=N;
	start.step=0;
	printf("%d\n",bfs());	
    
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值