poj-3468 A Simple Problem with Integers(线段树,树状数组区间求和)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 122299 Accepted: 37933
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
The sums may exceed the range of 32-bit integers.

题意:Q是求第a项到第b项的和,C是将第a项到第b项每项加c。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define MAX 100010
#define ll long long
using namespace std;
ll c[MAX],d[MAX],a[MAX];
int n,q;
int lowbit(int x)
{
    return x&(-x);
}
void update1(int x,ll u)
{
    for (int i = x;i<=n;i+=lowbit(i))
    {
        c[i]+=u;
    }
}
void update2(int x,ll u)
{
    for (int i=x;i<=n;i+=lowbit(i))
    {
        d[i]+=u;
    }
}
ll sum1(int x)
{
    ll s = 0;
    for (int i=x;i>0;i-=lowbit(i))
    {
        s+=c[i];
    }
    return s;
}
ll sum2(int x)
{
    ll s=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        s+= d[i];
    }
    return s;
}
int main()
{
    while(scanf("%d %d",&n,&q)!=EOF)
    {
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        ll t;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&t);
            a[i]=a[i-1]+t;
        }
        char s[5];
        while(q--)
        {
            scanf("%s",s);
            int x,y;
            ll z;
            if (s[0]=='Q')
            {
                scanf("%d %d",&x,&y);
                ll t1=a[y]-a[x-1];
                ll t2=(y+1)*sum1(y)-x*sum1(x-1);
                ll t3=sum2(y)-sum2(x-1);
                printf("%lld\n",t1+t2-t3);
            }
            else
            {
                scanf("%d %d %lld",&x,&y,&z);
                update1(x,z);
                update1(y+1,-z);
                update2(x,x*z);
                update2(y+1,-(y+1)*z);
            }
        }
    }
    return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值