POJ 3067 Japan (树状数组求逆序数---经典)

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27472 Accepted: 7430

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5


这题有巨坑!!!没指明K的范围,K的范围在10^6左右!!输出用long long 型

题意:日本东、西两沿海城市修高速公路,求交点总个数(交点处最多有两条公路)

分析:用树状数组做,a表示东边沿海城市,b表示西边沿海城市,先将ai从小到大排序,若ai==bi,则按bi小到大排序,然后求逆序数就行了。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
const int maxn=1e6+10;
struct node{
	int a,b;
}nt[maxn];
int C[1010];
int N,M,K;

bool cmp(const node& n1,const node& n2){
	return n1.a<n2.a || (n1.a==n2.a&&n1.b<n2.b); 
}

int lowbit(int i){
	return i&-i;
}

void update(int i){
	while(i<=M){
		C[i]++;
		i+=lowbit(i);
	}
}

int sum(int i){
	int ans=0;
	while(i){
		ans+=C[i];
		i-=lowbit(i);
	}
	return ans;
}

int main(){
	int T;
	scanf("%d",&T);
	int cnt=0;
	while(T--){
		scanf("%d%d%d",&N,&M,&K);
		for(int i=0;i<K;i++){
			scanf("%d%d",&nt[i].a,&nt[i].b);
		}
		
		sort(nt,nt+K,cmp);
		memset(C,0,sizeof(C));
		long long  tol=0;
		for(int i=K-1;i>=0;i--){
			update(nt[i].b);
			tol+=sum(nt[i].b-1);
		}
		
		printf("Test case %d: %lld\n",++cnt,tol);
	}
	return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值