ZOJ-3785

What day is that day?

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input
2
1
2
Sample Output
Sunday
Thursday
Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.

题意:今天是周六,求1+2^2+3^3+…………n^n天后是周几;

思路:题目其实不难,一眼就可以看出来是找规律的题,也可以打表,但是如果打表的数据太小是找不到规律的,当我们把打表的值打到294时可以看到在后面就是对前面的循环,所以就可以得到规律;

代码:

#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
int b[1000];
char a[10][10]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int main()
{
    memset(b,0,sizeof(b));
    ll i,j,sum=0,ans=0;
    for(i=1;i<295;i++)
    {
        ans=1;
        for(j=1;j<=i;j++)
        {
            ans*=i;
            ans%=7;
        }
        b[i]=ans+b[i-1];
    }
//    for(i=1;i<295;i++)
//        printf("%d ",b[i]%7);
//    printf("\n");
    int test;
    scanf("%d",&test);
    while(test--)
    {
        long long n,ans1=0;
        scanf("%lld",&n);
        ans1=b[n%294]%7;
        printf("%s\n",a[ans1]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值