ZOJ 3785 What day is that day? (找规律)

1、http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3785

2、题目:

What day is that day?

           


           

                Time Limit: 2 Seconds                                    Memory Limit: 65536 KB                           

           


           

It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input
2
1
2
Sample Output
Sunday
Thursday
Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.

3、思路:

打表i的i次方%7后的值,就可以发现42一循环

然后用公式计算出结果

int ans=(n/42%7*(s[42]%7)%7+s[n%42]%7)%7;

最后输出

str[ans]

即可

4、AC代码:

#include<stdio.h>
int s[45];
char str[7][10]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int main()
{
    s[0]=0;
    for(int i=1;i<=44;i++)
    {
        int flag=i%7;
        int ans=1;
        for(int j=1;j<=i;j++)
            ans=(ans*flag)%7;
        s[i]=ans;
    }
    for(int i=1;i<=44;i++)
        {s[i]+=s[i-1];}
    int t;
    while(scanf("%d",&t)!=EOF)
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int ans=(n/42%7*(s[42]%7)%7+s[n%42]%7)%7;
         printf("%s\n",str[ans]);
    }
}


 

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值