ZOJ3785What day is that day? 规律

It’s Saturday today, what day is it after 11 + 22 + 33 + … + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input

2
1
2

Sample Output

Sunday
Thursday

Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.

题目大意

今天是星期六。过了1^1+2^2 +…+n^n天,输入n,输出是星期几

解题思路

找规律,先打表,然后搜索前几个,发现294是一个循环节!

代码

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 300;
int f[maxn];
char week[7][20] = {"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday","Saturday"};
int main()
{
    int tmp = 6;
    for(int i = 1 ; i < 295 ; i ++) {
        f[i-1] = tmp;
        int tt = 1;
        for(int j = 1 ; j <= i ; j ++) {
            tt = (tt*i)%7;
        }
        tmp = (tmp+tt)%7;
    }
    int t;
    scanf("%d",&t);
    while(t--) {
        int n;
        scanf("%d",&n);
        n = n%294;
        printf("%s\n",week[f[n]]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值