xcode版本比较低 打开比较新的工程 Xcode导入项目出现cannot be opened because it is in a future Xcode project file format

Xcode导入项目出现cannot be opened because it is in a future Xcode project file format Adjust the project

 

 

 

The project at '/Users/yhgj/jhgh/kkjh/quybui.xcodeproj' cannot be opened because it is in a future Xcode project file format. Adjust the project format using a compatible version of Xcode to allow it to be opened by this version of Xcode.

 

根据提示,原因是因为这个工程是用更新版本的 Xcode 生成的,旧版本需要修改格式进行兼容后才能打开。

解决方法

第一步,找到工程文件,并右键选择“显示包内容”

第二步,找到内部的工程配置文件,使用文本编辑器打开

第三步,修改文件顶部的 objecVersion 字段为你的 Xcode 兼容的版本,我的是 50

 

 

第四步,保存后,重新打开工程,

参考

https://blog.csdn.net/amaoatao/article/details/107801270

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付 9.90元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值