hdoj 1796 How many integers can you find<容斥原理>

59 篇文章 0 订阅
7 篇文章 0 订阅


How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6741    Accepted Submission(s): 1957


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7
 

Author
wangye
 

Source


代码:

#include<cstdio>
#include<cstring>
int n,m,s;
int shu[12],mm;
int qu[1000010];
int gcd(int dd,int xx)
{
	if (dd%xx)
	return gcd(xx,dd%xx);
	return xx;
}
int GCD(int fu,int zz)
{
	int lp=1,a;
	if (fu<0)
	{
		lp=-1;
		fu=-fu;
	}
	if (fu>zz)
	{
		a=fu;fu=zz;zz=a;
	}
	if (zz%fu)
	return zz*fu/gcd(fu,zz%fu)*lp;
	return zz*lp;
}
int main()
{
	while (~scanf("%d%d",&n,&m))
	{
		bool fafe[10];
		memset(fafe,false,sizeof(fafe));
		for (int i=0;i<m;i++)
		{
			scanf("%d",&shu[i]);
		}
		mm=0;
		for (int i=0;i<m;i++)
		if (shu[i])
		shu[mm++]=shu[i];
		int ge=0;
		memset(qu,0,sizeof(qu));
		qu[ge++]=-1;
		for (int i=0;i<mm;i++)
		{
			int kk=ge;
			for (int j=0;j<kk;j++)
			qu[ge++]=GCD(qu[j],shu[i])*(-1);
		}
		s=0;n--;
		for (int i=1;i<ge;i++)
		{
			s+=n/qu[i];
		}
		printf("%d\n",s);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值