POJ - 3641 Pseudoprime numbers <快速幂加素数判定>

33 篇文章 0 订阅
7 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

 Status

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

Source




代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#define LL long long
LL wei[15],yu;
LL POW(LL aa,LL pp)
{
    LL lp=1;
    LL cheng=aa;
    while (pp)
    {
        if (pp&1)
        lp=(lp*cheng)%yu;
        cheng=(cheng*cheng)%yu;
        pp>>=1;
    }
    return lp;
}
int ko(int xx)
{
    if (xx==1) return 1;
    for (int i=2;i*i<=xx;i++)
        if (xx%i==0)
        return 1;
    return 0;
}
int main()
{
    LL p,a;
    while (scanf("%lld%lld",&p,&a),p+a)
    {
       yu=p;
        if (POW(a,p)==a&&ko(p))
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值