传送门:http://acm.hdu.edu.cn/showproblem.php?pid=5326
Work
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 749 Accepted Submission(s): 490
Problem Description
It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.
1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.
1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
Output
For each test case, output the answer as described above.
Sample Input
7 2 1 2 1 3 2 4 2 5 3 6 3 7
Sample Output
2
Author
ZSTU
Source
题意:
公司有n个人,给出n-1对领导关系,问有多少人领导k个人(包括下属的下属)。
数据规模很小,dfs暴搜。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
using namespace std;
#define eps 1e-8
#define LL long long
#define db double
#define maxn 10010
int n,k;
int vis[110];
vector <int> p[110];
void dfs(int u,int &t){
int len=p[u].size();
for(int i=0;i<len;i++){
int v=p[u][i];
if(vis[v]==0){
vis[u]=1;
++t;
dfs(v,t);
}
}
}
int main(){
while(~scanf("%d%d",&n,&k)){
for(int i=1;i<=n;i++)p[i].clear();
for(int i=1;i<n;i++){
int a,b;scanf("%d%d",&a,&b);
p[a].push_back(b);
}
int ans=0;
for(int i=1;i<=n;i++){
memset(vis,0,sizeof vis);
int t=0;
vis[i]=1;
dfs(i,t);
if(t==k)
ans++;
}
printf("%d\n",ans);
}
return 0;
}