UVA10014 - Simple calculations

公式:a1 = n * a0 / (n + 1) + an+1 / (n + 1) + ∑∑ci

题目:

Simple calculations


 Simple calculations 

The Problem

There is a sequence ofn+2 elements a0, a1,…, an+1(n <= 3000; -1000 <= ai 1000). It is known that ai= (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1,c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n.The next two lines consist of numbers a0 and an+1 eachhaving two digits after decimal point, and the next n lines contain numbers ci(also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in thesame format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1

1
50.50
25.50
10.15

Sample Output

27.85

解答:

#include<stdio.h>
int main()
{
	int t;
	double a0,an1,c;
	scanf("%d",&t);
	while(t--)
	{
		int i,j;
		double n,c,s=0;
		scanf("%lf%lf%lf",&n,&a0,&an1);
		for(i=0;i<n;i++)
		{
			scanf("%lf",&c);
			s+=(n-i)*c;
		}
		s*=2;
		printf("%.2lf\n",n*a0/(n+1)+an1/(n+1)-s/(n+1));
		if(t)
			printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值