hdu-1455-Sticks-深搜+剪枝

Sticks

Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero. 
 

Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
 

Output
The output file contains the smallest possible length of original sticks, one per line. 
 

Sample Input
  
  
9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0
 

Sample Output
  
  
6 5
 
/*有多个相同长度的木棍,将它们随机切成n个小木棍,现在要把它们还原,问原先的木棍长度最短可以是多少
小木棍的长度最大为50,n最大为64


首先将木棍长度从大到小排列,对可能的长度进行深搜,三个参数:目标长度、剩余长度、已有木棍的数量
当搜s[i]的返回值为0时,说明选s[i]这个单元不满足,如果此时(1)res==s[i],那么和s[i]等长的也没必要搜下去了,(2)res==sum,说明s[i]作为第一个木棍单元不能满足,则之后也不会满足
(3)当s[i]==s[i+1]时,s[i+1]也不用搜了

*/
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int n,m,m1,cc,flag;
int s[100],vis[100];
int cmp(int aa,int bb)
{
    return aa>bb;
}
int dfs(int sum,int res,int ct)
{
//    printf("sum=%d res=%d ct=%d\n",sum,res,ct);
   if(res == 0 && ct == n) return 1;
   if(res == 0)  res=sum;
   for(int i=0 ; i < n ; i++)
   {
       if( vis[i] || res < s[i]) continue;
       vis[i] = 1;
       if( dfs(sum,res-s[i],ct+1) )return 1;
       vis[i] = 0;
       if(res == s[i] || res == sum ) return 0;
       while(i+1 < n && s[i] == s[i+1])
       {
           i++;
       }
   }
   return 0;
}
int main()
{
    int i;
    while(scanf("%d",&n)&&n)
    {
        memset(vis,0,sizeof(vis));
        m1 = m = 0;
        for(i=0 ; i < n; i++)
        {
            scanf("%d",&s[i]);
            m+=s[i];
            if(m1<s[i])
                m1=s[i];
        }
        sort(s,s+n,cmp);
        for(i=m1 ; i <= m ; i++)
        {
            if(m%i!=0) continue;
            if( dfs(i,0,0) )
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值