POJ3061 Subsequence

求一个子序列的长度,这个子序列之和必须大于指定的一个值limit,且必须长度最小,求出这个序列的最小长度。
求出每一个位置的前缀和,前缀和一定是非递减的,对于一个前缀和Sumi   求出不大于Sumi-limit的Sumj,i-j+1就是一个满足大于limit要求的序列长度,枚举每一个序列的结束为止,求出序列的最短值,寻找位置J的过程可以用二分,也可以用lower_bound。
Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7905 Accepted: 3051

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

#include<iostream>
#include<algorithm>
#include<set>
#include<iterator>
#include<cstdio>

using namespace std;

const int MAXN=100000+5;

int preSum[MAXN];
int n,limt;
int ans;

int main(){
    int t,p;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&limt);
        ans=n+1;
        for(int i=1;i<=n;i++){
            int tmp,tans;
            scanf("%d",&tmp);
            preSum[i]=preSum[i-1]+tmp;
            tans=lower_bound(preSum,preSum+i,preSum[i]-limt)-preSum;
            if(tans>0) ans=min(ans,i-tans+1);
        }
        if(ans!=n+1)
            printf("%d\n",ans);
        else
            printf("0\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值