POJ2479 Maximum sum DP

一个含有n个整数的数字序列

求两个不想交的子串,这两个子串所有整数相加之和最大。

分别求出从左到右每一个位置所能得到的最大和,在求出从右到左每一个位置能得到最大和

对于每一个位置的最大和就是 FL[i-1]+FR[i] 然后对于每一个位置求出最大值即可。

注意的是子串不能为空

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32018 Accepted: 9858

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>

using namespace std;

const int INF=0x3f3f3f3f;
const int MAXN=50000+10;

int a[MAXN];
int f[MAXN];
int ans,n,sum;

int main()
{
    int t,tmp;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        f[0]=0;sum=0;tmp=-INF;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            sum+=a[i];
            if(sum>tmp)
                tmp=sum;
            f[i]=tmp;
            if(sum<0)
                sum=0;

        }
        sum=0;ans=-INF;tmp=-INF;
        for(int i=n;i>=2;i--){
            sum+=a[i];
            if(sum>tmp)
                tmp=sum;
            ans=max(ans,sum+f[i-1]);
            if(sum<0)
                sum=0;

        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值