一个含有n个整数的数字序列
求两个不想交的子串,这两个子串所有整数相加之和最大。
分别求出从左到右每一个位置所能得到的最大和,在求出从右到左每一个位置能得到最大和
对于每一个位置的最大和就是 FL[i-1]+FR[i] 然后对于每一个位置求出最大值即可。
注意的是子串不能为空
Maximum sum
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 32018 | Accepted: 9858 |
Description
Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).
Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Output
Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input
1 10 1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.
Huge input,scanf is recommended.
Source
POJ Contest,Author:Mathematica@ZSU
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=50000+10;
int a[MAXN];
int f[MAXN];
int ans,n,sum;
int main()
{
int t,tmp;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
f[0]=0;sum=0;tmp=-INF;
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
sum+=a[i];
if(sum>tmp)
tmp=sum;
f[i]=tmp;
if(sum<0)
sum=0;
}
sum=0;ans=-INF;tmp=-INF;
for(int i=n;i>=2;i--){
sum+=a[i];
if(sum>tmp)
tmp=sum;
ans=max(ans,sum+f[i-1]);
if(sum<0)
sum=0;
}
printf("%d\n",ans);
}
return 0;
}